Bonita Open Solution Version 5.3
QuickStart Guide

Contents
Change Notice .................................................................................................................. 4
Welcome to Bonita Open Solution! ................................................................................. 5
Download, install, and launch Bonita Open Solution 5.3 ................................................ 5
QuickStart Overview and Tutorial ................................................................................. 5
QuickStart Overview ......................................................................................................... 5
QuickStart Tutorial ............................................................................................................ 8
Prepare to Design a Process Graphically in Bonita Studio .............................................. 8
Launch Bonita Studio ....................................................................................................... 9
Draw Steps and Transitions ......................................................................................... 9
Create an Iteration and add an XOR gate ................................................................. 20
Add Conditions to Transitions .................................................................................... 21
Add Data to Process/Steps ......................................................................................... 25
Run a Process ............................................................................................................... 32
Complete a Process Case ........................................................................................    36
Customize Forms ........................................................................................................ 39
Summary ...................................................................................................................... 54
Feedback, Questions, and More Information ............................................................. 54

Figures

Figure 1. Welcome to Bonita Studio .................................................................................. 5
Figure 2. Bonita Studio ready to design a new Process ................................................ 6
Figure 3. Bonita User Experience provides an in-box to manage Processes and Cases ...... 7
Figure 4. Completed Web Purchase Process .................................................................. 8
Figure 5. Begin a new Process with a Start and a Step .................................................. 9
Figure 6. Enter General Details for Sales Review ....................................................... 9
Figure 7. Create a Group of Actors for Sales Review ...................................................... 10
Figure 8. Select the option to manually enter names for a User List ................................ 10
Figure 9. Name the Group ............................................................................................. 11
Figure 10. Define the Actors in this Group .................................................................... 11
Figure 11. The newly created Group shows up in the Groups list for the Sales Review Step .......... 12
Figure 12. Sales Employees is now the only group of Actors for this Step .................. 12
Figure 13. Use the Context Palette to draw new elements on the Whiteboard ............... 13
Figure 14. Name a new Step and enter its General Details ............................................ 13
Figure 15. Define the Actors for this Step .................................................................... 14
Figure 16. Select the Process Initiator as the Actor for this Step ................................... 14
Figure 17. Three views of the Bonita Studio Palette ..................................................... 15
Figure 18. Add Reject Step and define its General Details ............................................. 16
Figure 19. Add More Info Step and define its General Details ......................................... 16
Figure 20. Choose the Group of Actors for More Info .................................................. 17
Figure 21. Select the already defined Group Sales Employees ....................................... 17
Figure 22. Rename this Pool ......................................................................................... 18
Figure 23. Rename this Process Diagram ................................................................. 18
Figure 24. Add Express Delivery Step and define its General Details ........................................ 19
Figure 25. Add Archive Step and define its General Details ............................................ 19
Figure 26. Add an End event ................................................................................... 20
Figure 27. Rearrange the Process elements on the Whiteboard ........................................ 20
Figure 28. Add an XOR Gate ................................................................................. 21
Figure 29. Add Data to Details for Sales Review ................................................................ 21
Figure 30. Define a list for Sales Review ....................................................................... 22
Figure 31. Select a default value for the list ..................................................................... 23
Figure 32. Newly created Data (variable) shows up in Data for this Step ................................ 23
Figure 33. Define Conditions for Transitions .................................................................. 24
Figure 34. Transition Names appear on Whiteboard ...................................................... 24
Figure 35. Add Data to Details for Web Purchase Process (global variable) ......................... 25
Figure 36. Define a list at Process level (global list variable) ........................................... 26
Figure 37. Select a default value for the list ..................................................................... 27
Figure 38. Newly created Data (variables) show up in Data for the Process ......................... 27
Figure 39. Add Data to Details for More Info .................................................................. 28
Figure 40. Newly created Data (variable) shows up in Data for this Step .......................... 28
Figure 41. Newly created Data (variables) show up in this Step ....................................... 29
Figure 42. Add a Boolean Condition (true) to a Transition ............................................. 30
Figure 43. Add a Boolean (false) Condition to a Transition .............................................. 30
Figure 44. Transition Names appear on Process ............................................................. 31
Figure 45. Web Purchase Process Case initial Form (customer order form) ......................... 32
Figure 46. Fill in Web Purchase Process customer order Form to start a Case ..................... 32
Figure 47. Choose a Decision at Sales Review Step ........................................................ 33
Figure 48. Fill in Form presented at More Info Step ....................................................... 33
Figure 49. Fill in Form presented (again, after iteration) at Sales Review Step ...................... 34
Figure 50. Fill in Form presented at Pay Step ................................................................... 34
Figure 51. Web Purchase Case completed ....................................................................... 35
Figure 52. Completed initial Case shows up in archived Cases ......................................... 36
Figure 53. Bonita User Experience with completed Web Purchase Process test Case .......... 36
Figure 54. A completed Step in the Web Purchase Process test Case .................................... 37
Figure 55. Start another Case for the Web Purchase Process ............................................. 37
Figure 56. Fill in web purchase process customer order Form to start a new case ............... 38
Figure 57. Open Cases with steps to perform show up in the Inbox .................................... 38
Figure 58. Select Data to appear in new Form .................................................................. 39
Figure 59. Details panel for Web Purchase Form ............................................................. 39
Figure 60. Close Details and Overview panels to see the entire Form .................................. 40
Figure 61. initial Web Purchase Form ready to customize ............................................... 40
Figure 62. Add a blank widget to the top of the Form ...................................................... 41
Figure 63. Reorder the widgets in the Form .................................................................... 42
Figure 64. Remove the extra widget .............................................................................. 42
Figure 65. Customize General details for widget ............................................................. 43
Figure 66. Indicate that the Customer Name field must be completed in the Form ............ 43
Figure 67. Add a Validator ......................................................................................... 43
Figure 68. Customize Details for another widget ............................................................. 44
Figure 69. Create a drop-down list for a list of choices ..................................................... 44
Figure 70. Customized Form ....................................................................................... 45
Figure 71. Preview customized Form (to initiate Process) .................................................. 45
Figure 72. Select widgets to show in new Form ............................................................... 46
Figure 73. Arrange widgets in order .............................................................................. 47
Figure 74. Change widget from TextBox (live) to Text (read only) ................................................................. 47
Figure 75. Add a new Text widget .................................................................................................................. 48
Figure 76. Rename new widget ....................................................................................................................... 48
Figure 77. Select data value for Products text field ....................................................................................... 49
Figure 78. Choose Radio as the Field Type for decision ................................................................................. 49
Figure 79. Customized widgets in Sales Review Form ................................................................................. 50
Figure 80. Preview customized Form (for Sales Review Step) ...................................................................... 50
Figure 81. Create a Form for the Pay Step .................................................................................................... 51
Figure 82. Select Edit Expression to create an Expression in Groovy .......................................................... 51
Figure 83. Enter a Groovy expression to be evaluated and presented in the Message ................................. 52
Figure 84. Preview customized Form (for Pay Step) .................................................................................... 52
Figure 85. Customized Form (fields) presented in Bonita Open Solution default web Form ................... 53

Change Notice

BOS 5.3 contains new functions and presents a new user interface in both Bonita Studio and Bonita User Experience. This QuickStart Guide and tutorial show the updated interfaces. For more information about the new functions and for detailed information about Bonita Open Solution functionality, see the Bonita Open Solution User and Reference Guide.
Welcome to Bonita Open Solution!


Use this QuickStart Guide to get started with Bonita Open Solution and become familiar with designing a process with its graphic tools.

Download, install, and launch Bonita Open Solution 5.3

Download Bonita All-in-One. When the zipped folder has been downloaded, extract all files. To launch Bonita Open Solution and begin designing a process:

- open the unzipped bonita-all-in-one folder
- launch the BonitaStudio application file for your operating system.

QuickStart Overview and Tutorial

The Overview may help you to begin working with Bonita Open Solution quickly. After the Overview is a Tutorial that will take you through creating, running, and managing a Process step by step.

QuickStart Overview

![Welcome to Bonita Studio](#)

Select **New** to create a new process  
Open an existing .proc file

Import .bar files (created in BOS v5)  
Open some examples

You can also go directly to User Experience (++){ on the Tool Bar} where existing Processes and Cases are managed.
Bonita Studio

When you click New to enter Bonita Studio, the Whiteboard is ready to begin:

1. Draw your Process directly on the Whiteboard
2. Begin with a Start and the first Step
3. Or use the Palette to activate the Tools – click the element, drag to the Whiteboard
4. Define Details for the selected element, including:
   - Name
   - Step Type (Human, Automatic, Subprocess, etc)
   - Process (global) and Step (local) Data variables
   - Step Actors (Group, Individual)
   - Connectors (to external systems)
   - Form Contents
   - Transition Conditions (if-then)

5. Click Run to deploy a completed Process
6. Click User Experience to start and manage Process Cases

Figure 2. Bonita Studio ready to design a new Process
Bonita User Experience:

Processes and cases can be managed in an email-like interface with:
- Stars
- Labels
- Read and unread options

Figure 3. Bonita User Experience provides an in-box to manage Processes and Cases
QuickStart Tutorial

Follow the QuickStart tutorial example to:

- Design a complete Process graphically in Bonita Studio, as you
  - Draw Steps and Transitions using the graphic tools in the Bonita Studio Palette
  - Create an iteration and add a Gate
  - Add Conditions to Transitions
  - Add Details to the Process (global variables) and to Individual Steps (local variables)
- Run the Process you create
- Complete a Process Case and interact with the manual Steps
- See the Process, and the Cases you will create, in Bonita User Experience
- Return to the Process and design Forms using the Form Builder function of Bonita Studio

Prepare to Design a Process Graphically in Bonita Studio

Design a simple process, Web Purchase:

1. A customer orders an item from a web store.
2. A company sales employee processes the request manually (approves it, rejects it, or adds more information to the order).
3. If/when the customer’s order is approved, he/she pays for the order.
4. The customer chooses whether to have the item shipped by Express Delivery.
5. The transaction is archived.

The Process will look like this when completed:

![Completed Web Purchase Process](image)

(It might be helpful to keep this handy as you design the Process.)
Launch Bonita Studio


Draw Steps and Transitions

Start by defining the Steps to create a Web Purchase process.

The first step in this Process is to review and process a customer’s order. (In this tutorial, you’ll define the customer order after defining the process to handle it.)

Click the initial Step, if necessary, to highlight it. Note that its Context Palette is highlighted too.

![Figure 5. Begin a new Process with a Start and a Step](image)

Go to the Details panel, click General if necessary to highlight it, and enter:

![Figure 6. Enter General Details for Sales Review](image)
Before adding the next steps, define who will take action in this step - the Actor(s).

Click the **Actors in Details** for **Sales Review**. Note that Initiator show up here as a default Actor. However, since the Actor for this step is not the Initiator, you will change this.

![Select Group and Create](image1)

**Figure 7. Create a Group of Actors for Sales Review**

Complete the wizards:

![Select Bonita and User List](image2)

**Figure 8. Select the option to manually enter names for a User List**
When you define Actors in this Process, you’ll include “admin” in the list. When you Run the completed process, Bonita User Experience opens for the “Administrator” by default. Including the administrator in the list of Actors for all Human Steps ensures that you’ll see those Steps in the default User Experience inbox.

Click Finish to complete.
The Group you just created will now show in the list of Groups available for this Step.

![Image](Image)

**Figure 11.** The newly created Group shows up in the Groups list for the Sales Review Step

Highlight **Initiator** and *Remove* this Actor.

![Image](Image)

**Figure 12.** *Sales Employees* is now the only group of Actors for this Step

You’ll come back to this Step later to add additional Details.

At this point in the process, the sales employee can choose to:

1) validate the request and the customer can pay; OR  
2) reject the request; OR  
3) enter more information relevant to the customer’s order.

Accordingly, next add 3 Steps, all connected to Sales Review, as detailed below.
Sales Review should still be highlighted. (If not, click it.) The Context Palette to the right of the Step is highlighted too.

Click on the Step tool (circled) and drag a new Step onto the Whiteboard

Figure 13. Use the Context Palette to draw new elements on the Whiteboard

Be sure that the new Step is highlighted. Go to Details and click General to name it:

Figure 14. Name a new Step and enter its General Details

Note that there is a red warning in the upper right corner of the Step. Hover your mouse over it to see: The Step has no group or user.
Click on **Actors** to define:

![Actors Definition Screen](image1)

**Figure 15. Define the Actors for this Step**

![Assign Actors Dialogue](image2)

**Figure 16. Select the Process Initiator as the Actor for this Step**
Now add the other 2 Steps connected to Sales Review. First, **Reject**.

This time use the **Palette** to add a Step.

You can select the Palette that you prefer. The first version shows element icons only; the second, a simple list of element types (which you can further define after placing on the Whiteboard), and the third, a full list of all elements.

![Figure 17. Three views of the Bonita Studio Palette](image)

You can click and drag an automatic Step into place, or click on the cursor symbol, the element, and then on the Whiteboard.
In Details -> General:

Figure 18. Add Reject Step and define its General Details

Then, More Info. In Details -> General:

Figure 19. Add More Info Step and define its General Details
Then in Details -> Actors -> Group, select Choose:

![Choose Group](image)

**Figure 20. Choose the Group of Actors for More Info**

Complete the Assign Actors wizard:

![Assign Actors](image)

**Select Sales Employees**

**Click Finish**

**Figure 21. Select the already defined Group Sales Employees**

You’ll add the information that determines the necessary conditions (if-then) for each of these 3 Transition paths later.
Rename the Pool from *My Process* to *Web Purchase*. Click on the Pool to deselect all elements. Click on *MyProcess -> Details -> Pool*:

Enter
Name: Web Purchase
Version: 1.4
Description: Simple item purchase from Web site - tutorial example

**Figure 22. Rename this Pool**

Rename the Process Diagram from *MyProcessDiagram* to *Web Purchase Diagram*. Click outside the Pool to deselect all elements. Click on *MyProcessDiagram -> Details -> Diagram*:

Enter
Name: Web Purchase Diagram
Version: 1.4
Description: Simple item purchase from Web site - tutorial example

**Figure 23. Rename this Process Diagram**
Save the Process. The Whiteboard tab is now labeled Web Purchase Diagram (1.0) and the Pool is now labeled Web_Purchase. Note that the red warnings have disappeared also. Continue the Process definition.

As the customer completes the Pay Step, he/she will choose whether the item is to be sent express. Click Pay and use the Context Palette to add a new Step. Name it Express Delivery.

End this Process by archiving the interaction. Add a Step after Express Delivery, go to Details -> General, and name it Archive.
Now that all the Steps have been defined, add the **Transitions** to connect them.

As “no-express-delivery” requests will also be archived, add a **Transition** between **Pay** and **Archive**. Select → **Transition** from the Palette, click **Pay** and drag the arrow to **Archive**.

As rejected requests will also be archived, add a **Transition** between **Reject** and **Archive**. Select → **Transition**, then **Reject** and drag to **Archive**.

End the process – highlight **Archive** and add an **End**. Drag the Event into place, and select the red End event to create and End.

![Figure 26. Add an End event](image)

Click and drag the individual elements in your Process to rearrange them if you wish. Unruly transition arrows can be moved manually by selecting the Transition, and clicking or unclicking the Automatic layout box in its Details.

![Figure 27. Rearrange the Process elements on the Whiteboard](image)

The general sequence of the Process is nearly defined. Now add missing information to complete it.

**Create an Iteration and add an XOR gate**

Note that **More Info** has an input but no output. In this simple tutorial example Process, the output will be returned to the sales employee so he/she can add information and complete the approval.

However, Sales Review will then have two inputs. A **Gate** will define how these inputs should be treated. Sales Review can proceed with either input, so an **XOR Gate** is needed.
Bonita Open Solution 5.3 QuickStart Guide

Figure 28. Add an XOR Gate

Note: If there is no XOR gate to resolve multiple inputs, Bonita Open Solution treats them as XOR by default. The Step will take the first to arrive and proceed.

Add Conditions to Transitions

Note that Sales Review has 3 outputs, and each Case of the Process will follow only one of them. One way to define how a Process will “choose” to follow which path is to define specific Data in the Details of Sales Review. Then define a Condition for each Transition.

Select Sales Review and in its Details, add Data:

Figure 29. Add Data to Details for Sales Review

In the next wizard, define the Data type as a List of options, give it a name, and add the list items.
Figure 30. Define a list for Sales Review

Enter
Name: decision
Description: Multiple options require a decision

Select
Data type: List
Name: Approval (list): Approval
Description: Decision to approve, reject, or add more info
Add: Approve, Reject, and More Info
The list variable now shows in **Sales Review -> Details -> Data**.

![Figure 31. Select a default value for the List](image)

![Figure 32. Newly created Data (variable) shows up in Data for this Step](image)
Associate each Transition output from **Sales Review** with its associated decision **Condition**. Select each Transition in turn:

![Diagram of Transition Outputs]

**Sales Review - Pay:**
- **Name**: if approved
- **Conditions**: decision == “Approve”

**Sales Review – Reject:**
- **Name**: if not approved
- **Conditions**: decision == “Reject”

**Sales Review - More Info:**
- **Name**: add a comment
- **Conditions**: decision == “More Info”

Figure 33. Define Conditions for Transitions

The Name of each Transition now shows on the Process. Click and drag to move them if you wish.

![Diagram of Transition Names]

Figure 34. Transition Names appear on Whiteboard

Note that Pay has two outputs, too. You’ll return to modify its Details in a similar way. But first...
Add Data to Process/Steps

Complete the Details, beginning with Data, for the global Process Web Purchase. This information will be used to generate the form that the customer completes to begin the process. Global data is accessible to any Step in the Process; while local data is available only to the Step where it is defined.

Add 4 global Data variables: 3 Text and one List. Click on the Pool, go to Web Purchase Details, select Data, then Add.

![Figure 35. Add Data to Details for Web Purchase Process (global variable)](image)

Continue, and Add customerPhone and customerEmail as simple Text variables with no default values.
For the last variable, add a **List of options**.

**Figure 36. Define a list at Process level (global list variable)**

- **Enter**
  - **Name**: products
  - **Description**: Available products

- **Select**
  - **Data type**: List
  - **Name**: Promotional Products
  - **Description**: Special prices online

- **Add**
  - TV
  - mobile phone
  - laptop
Select a default:

Figure 37. Select a default value for the list

Note that Web Purchase -> Details -> Data now contains 4 global variables.

Figure 38. Newly created Data (variables) show up in Data for the Process
Now complete the details for the More Info and Pay Steps:

Go to More Info -> Data and select Add:

![Figure 39. Add Data to Details for More Info]

The new variable now shows in Details.

![Figure 40. Newly created Data (variable) shows up in Data for this Step]
Go to **Pay ->Data** and select **Add**.

Add 2 text variables and 1 Boolean variable:

Add 2 text variables:

- **Name:** creditCardNumber
- **Description:** Customer's Credit Card
- **Data type:** Text

and

- **Name:** expirationDate
- **Description:** Card valid until
- **Data type:** Date
- **Default value:** Now

And Add a Boolean yes/no for the choice of express delivery:

- **Name:** chooseExpressDelivery
- **Description:** If yes - send express; if no - send regular post
- **Data type:** Boolean
- **Default value:** true

---

*Figure 41. Newly created Data (variables) show up in Data for this Step*
Here is where you’ll define the conditions for the Pay Step’s output path.

Add “if-then” **Conditions** to 2 Transitions.

Select the **Transition** between **Pay** and **Express Delivery**. In the **Conditions** field, enter `chooseExpressDelivery`. This Groovy expression evaluates to `chooseExpressDelivery=true`.

Select the **Transition** between **Pay** and **Archive**. Change its name to “if no.” In the **Conditions** field, enter `!chooseExpressDelivery`. This Groovy expression evaluates to `chooseExpressDelivery=false`.

**Figure 42. Add a Boolean Condition (true) to a Transition**

**Figure 43. Add a Boolean (false) Condition to a Transition**
The Name of each Transition now shows on the Process.

The Process is now complete and ready to deploy/run. Save your Process.
Run a Process

To Run (deploy) your process, click the Run icon from the Task bar or select Run from the Menu bar.

After a few moments, Bonita Open Solution will present a series of status messages. The deployment is successful. Note that you are logged in as the Admin.

The Process can now run Step by Step. The forms are presented in the default Bonita Form and default Bonita Web Application, which you have not customized (the fields are not presented in any specified order, they are labeled with the variable name, and so on). After you complete the Run a Process section, you can return to Bonita Studio and change these forms (see Customize Forms).

Figure 45. Web Purchase Process Case initial Form (customer order form)

At each Step, you can take action as you have previously defined it. (Note that you as Administrator are testing the manual actions of the Customer (Initiator) at the beginning of the Process and at Pay, and of the Sales Employee at Sales Review and More Info.)

Figure 46. Fill in Web Purchase Process customer order Form to start a Case
The information entered by the “customer” is presented for approval in the Sales Review Step. You can now Approve, Reject, or request to enter More Information. Note that the Step candidates include the individuals you have identified as Sales Employees, plus the admin.

Figure 47. Choose a Decision at Sales Review Step

Figure 48. Fill in Form presented at More Info Step
Figure 49. Fill in Form presented (again, after iteration) at Sales Review Step

As "Sales Employee": select Approve and Submit

Figure 50. Fill in Form presented at Pay Step

As "Customer": Fill in Credit Card Number and Expiration Date, select Express Delivery and Submit

Note that at this step, the Form would be presented to the Initiator, but by default the admin has access to activate it.
Figure 51. Web Purchase Case completed

Click on **Bonita User Experience** (circled in red) to open.
Complete a Process Case

Use Bonita User Experience to run multiple Cases of this Process. Note that you can also open the User Experience by clicking on the User XP icon on the Task bar in Bonita Studio.

Your inbox now contains a record of all the actions you have been involved in. You can look at these actions at any time.

Since the case you have just run has no open Steps – it was completed – it will show up in Cases -> Show archived cases only.

Figure 52. Completed initial Case shows up in archived Cases

Click on Web Purchase in the Case list to expand it

Figure 53. Bonita User Experience with completed Web Purchase Process test Case
The Case Overview shows the Steps executed in your test Case

**Figure 54. A completed Step in the Web Purchase Process test Case**

To run this Process again, return to the Inbox, go to **Start a Case** and select Web Purchase:

**Figure 55. Start another Case for the Web Purchase Process**
The Process starts again with a new Case.

![Image](image1.png)

**Figure 56. Fill in web purchase process customer order Form to start a new case**

Fill data in the order form presented, and Submit.

Return to the Inbox to see the open Case.

![Image](image2.png)

**Figure 57. Open Cases with steps to perform show up in the Inbox**

Try running several Cases to try different choices at each Step.
Customize Forms

To customize the way information is presented to the end user in the four Bonita Open Solution-generated forms in this tutorial example, return to Bonita Studio.

Add a case start Form

The first Form presented in this process, Case Start: Web Purchase is the one that begins this process. To customize it, click on the Process Pool. Go to Details -> Forms -> Add.

A wizard appears with all of the Data variables available for this Form.

![Create a new Form](image)

Figure 58. Select Data to appear in new Form

For this example, leave all choices checked and Finish to continue. A default version of the Form will appear, along with the Details panel for the Form.

![Details panel for Web Purchase Form](image)

Figure 59. Details panel for Web Purchase Form

To see the entire Form, close the Details and Overview Panels (click on the X in the upper right corner of each panel).
Each Data field in the Form is presented in a widget. You can customize the order and presentation of each widget in the Form.
Bonita Open Solution 5.3 QuickStart Guide

Reorder widgets in Form

It’s easier to move widgets when there is an empty space. Add one to the top of the Form by clicking on the “add a row” symbol at the top left:

Figure 62. Add a blank widget to the top of the Form

Now you can click and drag the “customerName” widget to the first row of the Form.
Click and drag the other widgets into the order you want.

To remove the extra widget, click on the “remove a row” symbol at the bottom left.
Customize widgets in Form

Now you can customize the details for each widget. Begin with `customerName`; click the widget and go to Details. (You may need to restore the View to see the Details panel again. Go to the Menu bar and select View -> Reset view.)

![Customize General details for widget](image)

Figure 65. Customize General details for widget

Go to Options and select Is mandatory.

![Indicate that the Customer Name field must be completed in the Form](image)

Figure 66. Indicate that the Customer Name field must be completed in the Form

There are no changes to Data, Validators, Grid, or Appearance for this widget. Continue to the next widget, `customerEmail`. Change the Show label field to Email address.

Go to Details -> Validators -> Add.

![Add a Validator](image)

Choose
- **Validator type**: Mail
- **Enter**
- **Error message**: this does not appear to be a valid email address

Figure 67. Add a Validator
If a red X appears in the field, save the Diagram and it should resolve and disappear.

There are no changes to Data, Grid, or Appearance for this widget. Continue to the next widget, customerPhone. Go to Details -> General.

![Customer Phone Details](image)

**Figure 68. Customize Details for another widget**

There are no changes to Data, Validators, Grid, or Appearance for this widget. Go to Options and select **Is mandatory**.

Continue to the next widget, products. Go to Details -> General.

![Products Details](image)

**Figure 69. Create a drop-down list for a list of choices**
For this Data variable, a drop-down list allows the user to select more than one item from a Data list.

Figure 70. Customized Form

**Preview** the Form you have created by selecting **Preview** from the Task Bar.

Figure 71. Preview customized Form (to initiate Process)

Close the Form and save it by clicking on the X on its tab.
Add a Sales Review Form

Unlike the “live” Form presented to the Initiator to start this Process, the Form at the Sales Review Step primarily serves to carry data forward for review. There is only one “live” field for the Sales Employee, the “Decision” choice.

Create a Form here to do this.

Go to Sales Review -> Details -> Forms -> Add. Again select all Data available here to carry into the Form.

![Create a new Form](image)

**Figure 72. Select widgets to show in new Form**

Add a new space to the Form just above the Submit button. Drag and drop the decision widget to this space. Re-arrange the other widgets (see Figure below) and delete the resulting empty widget.
Reformat the widgets for **customerName**, **customerEmail**, **customerPhone**, and **products** to carry forward data already entered by the Initiator.

Click on the **customerName** widget to see its Details panel. Here you can change its Field Type from TextBox (live) to Text (read only).

Repeat this for **customerEmail**, and **customerPhone**.
To change **products** to a read-only text field, you will need to redefine a widget.

Delete the old **products** widget.

Use the ▶ to insert a new widget. Click and drag a Text widget from the Palette into the new space.

![Add a new Text widget](image)

Figure 75. Add a new Text widget

Click on the new widget, go to Details -> General and rename the widget and Label.

![Rename new widget](image)

Figure 76. Rename new widget
In the new Products widget, go to General -> Data. Select ${products}.

![Image](BonitaOpenSolution5.3QuickStartGuide.png)

**Figure 77. Select data value for Products text field**

Last, go to decision -> General. Choose Radio as the Field Type. Radio allows only one choice from a Data list. This is the only “live” field in this Form.

![Image](BonitaOpenSolution5.3QuickStartGuide.png)

**Figure 78. Choose Radio as the Field Type for decision**
Preview the Form you have customized.

Customize the Form in More Info in the same way. Leave the field for comment (Add comment) as a live TextBox.

The Form for the Step Pay will again be presented to the Initiator, so you can add a widget to summarize the customer’s order.

Click on Pay and go to Details -> Forms -> Add.
When the Create a New Form wizard appears, select only `chooseExpressDelivery`, `creditCardNumber`, and `expirationDate`.

Re-arrange the widgets as shown in the figure below. Add a new widget by clicking and dragging the `Message` widget into the top spot.

![Figure 81. Create a Form for the Pay Step](image)

Go to Details and change the following widget labels:

- `creditCardNumber`: Credit Card Number
- `expirationDate`: Expiration Date
- `chooseExpressDelivery`: Do you want express delivery? Check if yes:

For the new Message widget, go to Details -> Data. For Initial value, select Edit Expression. Create a Groovy expression to present a message in the Form.

![Figure 82. Select Edit Expression to create an Expression in Groovy](image)
Figure 83. Enter a Groovy expression to be evaluated and presented in the Message

Preview the Form you have customized.

Figure 84. Preview customized Form (for Pay Step)

Close and Save the Form. Save your Process as Web Purchase Diagram 1.4. Run it.

You should now see the Forms you have designed presented in the default Bonita Open Solution Web Form.
Figure 85. Customized Form (fields) presented in Bonita Open Solution default web Form
Summary

You have used only some of Bonita Open Solution's functions, specifically:

The graphical interfaces of Bonita Studio, to create a complete Process by
- drawing Steps and assigning them as Human or Automatic;
- assigning Actors to Human Steps;
- adding global variables to the Process and local variables to Steps, which in turn have been
  used to create interactive forms;
  - defining text and list variables;
  - defining a Boolean variable;
- defining Conditions on Transitions to manage multiple output choices from a Step; and
- defining a Gate to manage multiple inputs to a Step in an iteration.

The default Forms interface of Bonita User Experience:
- to Run a completed Process and enter information into the interactive forms created from
  your variables.

The e-mail like interface of Bonita User Experience:
- to see the completed Case Steps;
- to consult the Case history
- to Run an additional Case (or two, or several) of your Process.

The Form Builder customization feature of Bonita Studio:
- to select which data fields to present in a Form
- to configure how those data fields will be presented to the User.

If you explore a bit more in Bonita Open Solution, you will find other functionalities not addressed in
this QuickStart - for example, in the Details for a Step, you can define Connectors to link to external
databases and to messaging systems, and much more.

Feedback, Questions, and More Information

For an expanded explanation of the functionalities in Bonita Open Solution, see the Bonita Open
Solution User and Reference Guide.

We welcome your feedback. Use the BonitaSoft Forum to let us have it!
(www.bonitasoft.org/forum)

The BonitaSoft Forum is the place for your questions too. And check out our Bug Tracker, Source Code, and more.
(www.bonitasoft.org/index.php)

Join the BonitaSoft Community and get our Newsletter, access to advance information, and more.
(www.bonitasoft.com/community/join.php)

For more information, contact us at BonitaSoft.
(www.bonitasoft.com/company/contact.php)

Have fun with Bonita!