Change Notice

Bonita Open Solution 5.5 contains new features and presents updated interfaces in both Bonita Studio and Bonita User Experience.

For links to more information about new Bonita Open Solution functions, see Feedback, Questions, and More Information in this QuickStart guide.
## Contents

Change Notice ........................................................................................................................... 2  
Contents ................................................................................................................................. 3  
Figures ................................................................................................................................... 4  
Part 1. Overview.......................................................................................................................... 5  
  1.1 Download, install, and launch Bonita Open Solution 5.5 ...................................................... 5  
  1.2 General Description ........................................................................................................... 5  
Part 2. Bonita Studio .................................................................................................................. 8  
  2.1 Menu bar ........................................................................................................................... 8  
  2.2 Task bar ............................................................................................................................ 8  
  2.3 Whiteboard ....................................................................................................................... 8  
  2.4 Palettes ............................................................................................................................ 10  
    2.4.1 Context palette ........................................................................................................... 11  
  2.5 Overview panel and Treeview ............................................................................................ 12  
  2.6 Detail Panel ....................................................................................................................... 14  
    2.6.1 General ...................................................................................................................... 14  
    2.6.2 Application ............................................................................................................... 15  
    2.6.3 Appearance ............................................................................................................... 16  
    2.6.4 Simulation ................................................................................................................. 16  
Part 3. Bonita Studio Form Builder ............................................................................................ 17  
  3.1 Form Builder Grid ............................................................................................................. 18  
  3.2 Form Builder Palette ......................................................................................................... 18  
  3.3 Form Builder Details Panel ............................................................................................. 18  
  3.4 Form Preview ................................................................................................................... 18  
  3.5 Forms presented in Web application ................................................................................. 18  
Part 4. Bonita User Experience ................................................................................................. 18  
  4.1 Processes ......................................................................................................................... 20  
  4.2 Organization .................................................................................................................... 20  
  4.3 Reporting ......................................................................................................................... 20  
  4.4 User Labels ...................................................................................................................... 20  
Part 5. Feedback, Questions, and More Information .............................................................. 20
Figures

Figure 1 Welcome to Bonita Studio in Bonita Open Solution .................................................. 5
Figure 2 Design a Process on the Bonita Studio Whiteboard .................................................. 6
Figure 4 Create forms in Bonita Form Builder ........................................................................ 6
Figure 5 Default Bonita form .................................................................................................. 7
Figure 6 Bonita User Experience ............................................................................................ 7
Figure 7 Bonita Open Solution Menu bar ................................................................................ 8
Figure 8 Bonita Open Solution Task bar .................................................................................. 8
Figure 9 Bonita Studio ready for a new Process design ............................................................ 9
Figure 3 Change the size of the Task Bar (Cool bar) ................................................................. 9
Figure 10 Pools and lanes on the Whiteboard (within a single Process Diagram) .................. 10
Figure 11 Advanced, Simple and Detailed Palettes ................................................................. 11
Figure 12 Two examples of the Context Palette: Step and Gateway ........................................ 12
Figure 13 Overview view ........................................................................................................ 12
Figure 14 Pool view ................................................................................................................ 13
Figure 15 Tree view ............................................................................................................... 13
Figure 16 Search Treeview ..................................................................................................... 14
Figure 18 Overview ................................................................................................................ 14
Figure 17 Reset Overview ...................................................................................................... 14
Figure 19 Detail panel tabs ..................................................................................................... 14
Figure 20 Detail Panel example: General tab at the Diagram level .......................................... 15
Figure 21 Detail Panel Example: Application tab at the Pool level ........................................ 16
Figure 22 Appearance tab ...................................................................................................... 16
Figure 23 Simulation tab ........................................................................................................ 16
Figure 24 Add a Form ............................................................................................................. 17
Figure 25 Bonita Studio Form Builder .................................................................................... 17
Figure 26 Bonita User Experience – User View ..................................................................... 19
Figure 27 Bonita User Experience – Administration View ..................................................... 19
Welcome to Bonita Open Solution!

Use this QuickStart Guide to get started with Bonita Open Solution and become familiar with its graphic tools for process design.

Part 1. Overview

1.1 Download, install, and launch Bonita Open Solution 5.5

Bonita Open Solution 5.5 is now available from the Download BPM software and documentation page at www.bonitasoft.com. (http://www.bonitasoft.com/products/BPM_download_all.php)

When the zipped file has been downloaded, extract all files to a target folder. To launch Bonita Open Solution and begin designing a process:

- Open the target folder.
- Launch the BonitaStudio application file for your operating system.

1.2 General Description

Bonita Studio is the graphic process design interface of Bonita Open Solution. The Welcome screen, shown below, is what you see when you launch Bonita Open Solution.
Whiteboard in Bonita Studio

The screen shown below shows where you draw your processes.

![Whiteboard in Bonita Studio](image)

**Figure 2 Design a Process on the Bonita Studio Whiteboard**

Form Builder in Bonita Studio

Form Builder, shown below, is used to create and customize the fields which will be displayed in end user forms.

![Form Builder in Bonita Studio](image)

**Figure 3 Create forms in Bonita Form Builder**

Forms created in Form Builder can be deployed via stand-alone web-based applications (Bonita Open Solution default applications are included, as shown below).
These forms can be widely distributed, accessible by your end users via your web portal or standalone web page, integrated into your company or organization’s web site or intranet.

**Bonita User Experience**

Bonita User Experience is the portal where deployed processes are managed.

Bonita User Experience can be used:

- by the Process Developer to develop and test the management of tasks (steps) in cases
- by the end users who can take action in tasks (steps)
- by both end users and Process Administrators to manage process cases, according to access permission
- by the Process Administrator to manage deployed processes, user access, and more.
Part 2. Bonita Studio

When you click New to enter Bonita Studio, you’ll see the Whiteboard and several bars and panels that provide tools for Process design. More information on each of these panels follows in this guide.

2.1 Menu bar

The Menu bar allows you to choose actions from drop-down menus.

<table>
<thead>
<tr>
<th>Process</th>
<th>Edit</th>
<th>Run</th>
<th>View</th>
<th>Extensions</th>
<th>Connectors</th>
<th>Simulation</th>
<th>Help</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open, save, import and export, print, and more</td>
<td>Undo, redo, copy, paste, and more</td>
<td>Run, deploy, preview forms, open User Experience and more</td>
<td>Reset the Whiteboard and panels if you have minimized any of them and change the size of the Task bar (Coolbar)</td>
<td>Browse and add or remove processes, resources, and more from the Community</td>
<td>Create, edit, test, import connectors, define actor selectors, define filters, and more</td>
<td>Manage, import, export simulation resources and run simulations</td>
<td>Return to the welcome page, jump to the Help page, find Bonita Studio and Bonita Execution Engine logs</td>
</tr>
</tbody>
</table>

2.2 Task bar

Use the Task Bar to start a new Process, Open an existing process, Save, Print, Import, Export, Copy, Paste, Run a Process, Debug a process and change Preferences. You can also open the User Experience from here and Preview Forms as you design them. Jump to the central Help page or return to the Welcome page from here.

The Task bar can be reduced in size or made to disappear (via the View menu in the Menu bar).

2.3 Whiteboard

The Whiteboard offers a graphic interface to draw processes. It allows you to draw, inside a single Process Diagram, one or more Pools, and multiple Lanes within each Pool.
The design space on the whiteboard can be increased by reducing the size of the Task bar (go to Menu Bar -> View -> Coolbar and select Hidden, Small, or Normal.)

You can also hide the Design Palette at the left – click on the Hide Palette arrow. To restore the Task Bar and Design Palette, go to Menu Bar -> View -> Reset View.

Pools and Lanes are defined in BPMN 2.0.

A Pool is equivalent to a stand-alone Process and contains all the elements and resources needed to deploy a complete Process. It can contain one or more Lanes which might represent different organizations participating in the process.

Lanes are never standalone; they can exist only within a Pool. They are useful to organize a Process visually, and can be specifically associated with a group of Actors.

When you save a Process Diagram, all Processes and all resources are saved together. When you export a Diagram, each Pool (Process) in the diagram is saved as an individual *.bar file in the directory or folder you choose.
2.4 Palettes

The Design Palettes provide all the graphical elements needed to design a Process. The elements in the 3 different Design Palettes, and in the Context Palette, correspond to the definitions of design elements in BPMN2.

Simply click on a tool icon in any of the Palette views, and drag it into place on the Whiteboard.
2.4.1 Context palette

When you click on an element on the Whiteboard, you’ll see a highlighted Context Palette. Use this to avoid the need to click back-and-forth from the Design Palettes at the left to the Whiteboard as you design. Design faster!
2.5 Overview panel and Tree view

The Overview panel stays fixed as you design and modify a process. It presents the entire Whiteboard (with all Pools) in a zoomed-out view.

The Overview panel also offers a Tree view option, which presents all the elements contained in a process as an expandable or collapsible Tree view. It is also searchable.

Switch between a zoom out view and a tree view when viewing the process pool or form.

Figure 12 Two examples of the Context Palette: Step and Gateway

Figure 13 Overview view

Below, is the Pool view showing Pools and Lanes.
Below is the Tree view showing the detailed elements in a process.
Search in the Tree view field “type filter text” for certain elements.

![Search Tree view](image1)

Figure 16 Search Tree view

![Overview](image2)

Figure 17 Overview

 Restore all panels by selecting View > Reset view from the Menu Bar.

![Reset view](image3)

Figure 18 Reset Overview

You can hide the Overview or Detail Panels by clicking on the ❌ in the Overview bar.

### 2.6 Detail Panel

Use the views (tabs) in the Detail Panel to define and customize the entire Process, individual Tasks, User Forms, Simulation, and more. The Details panel organizes many customization functions in its 4 tabs: **General, Application, Appearance, Simulation**.

![Detail panel tabs](image4)

Figure 19 Detail panel tabs

Click on any element in the Whiteboard to see the Details panels associated with it.

### 2.6.1 General tab

At the Diagram level (outside a Pool), the **General** tab allows you to:
- Click on the **Edit** button to change the Diagram name and version
- Define **Actor Selectors** that will dynamically fetch Actors
- Manage the various **Dependencies** (Java libraries needed for process to run connectors, validators, third-party libraries, scripts) for the Processes in this Diagram
When a Pool or Step is selected, the **General** tabs allow you to:

- Change the Pool name and version and the Step name
- Define User XP characteristics that will be applied in User Experience when the deployed Process is run
- Define global and local data variables
- Define Actor Selectors that will dynamically fetch Actors
- Define Connectors to external systems
- Manage the various dependencies for this Pool

### 2.6.2 Application tab

The **Application** tab allows you to define Forms at the Pool and Step level. You can also define what order the Forms appear in. Entry forms are user-interactive; View and Overview forms are read-only (for example, for summarizing data or presenting information).

At the Pool level, the Application tab also provides functions to change external web resources and the look-and-feel for the user interfaces (forms, welcome page, log-in page, confirmation messages, and more).

The **Transient Data** tab located here also allows you to define variables that are temporarily useful within any form.

The **Form Builder** is located in the Application tab and is described in more detail in [Part 3 Bonita Studio Form Builder](#).
2.6.3 Appearance tab

The Appearance tab allows you to change the color and font of the text labels in the Pool and Step.

2.6.4 Simulation tab

The Simulation tab is used to define the parameters needed to develop and run a simulation of the process.
Part 3. Bonita Studio Form Builder

Use the **Form Builder** in Bonita Studio to: create Forms for each Step, for the Process initialization, and for overviews during the Process run. You can find the Form Builder in the Application tab at the Pool and Step levels. It will appear when you select Add (Entry Pageflow, View Pageflow, or Overview Pageflow) and complete the *Create a new Form* wizard.

Use **Entry Pageflow** to create pages to display to the End User – they allow data entry (interactive). Use **View Pageflow** to create pages that are visible when you consult Cases in the List of Cases (history) in User Experience.

![Figure 24 Add a Form](image)

![Figure 25 Bonita Studio Form Builder](image)

- Place the fields of the Form in a grid (rows and columns)
- Use the **Palette** to select the widgets that allow you to format each field
- See the **Overview** of the Form
- Use the Details Panel to customize the entire Form, individual Form pages, individual fields, and more
3.1 Form Builder Grid

Add, delete, and move field boxes around the Form builder grid to create rows and columns.

3.2 Form Builder Palette

The Form builder Palette contains widgets that can be applied to data fields in the Form using click-and-drag. The widget(s) you can apply depend on the type of variable you’ve defined; for example: checkbox, drop-down list and radio buttons can be applied to a List of Options.

3.3 Form Builder Details Panel

Use the tabs General and Appearance in the Form Builder Details Panel to name the Form, add validators to restrict the type of data a field will accept, and customize the appearance of a field.

3.4 Form Preview

Preview the form by clicking on the Preview icon in the Task bar, or by selecting Run -> Preview Form from the Menu bar.

3.5 Forms presented in Web application

Forms are deployed when the Process is Run. The forms are presented in one of the five default Bonita Web Applications. You can change this default to another Bonita Open Solution default model, or deploy Forms in your own Web application.

Part 4. Bonita User Experience

When you Run a Process, it will deploy the Forms you have designed and/or deploy the Bonita User Experience (User XP) portal.

Run will deploy the User Experience web application in the embedded server, open the User Experience web page in a web browser, deploy the process web application (with any forms you have created), and start the Process with a web page instead of the Bonita User Experience inbox view.

You can also open Bonita User XP directly from the Task bar. This function will deploy User Experience web application in the embedded server and open the Bonita User Experience inbox view in a web browser.

This portal, which resembles an email inbox, contains information about Process cases as they run task by task. In User XP, tasks are called Steps.

Forms can also be deployed inside User XP Steps, depending on the Process design.

The Bonita User XP portal provides an Inbox and several control panels and dashboards that provide tools for Process and Process Case management.
Note: A Process Case contains all information related to a single specific instance of the generic Process.

There are 2 different default views in Bonita User XP: simple “User View,” and “Administration View.”

The User XP portal that opens by default is in the “User View,” that is, the version presented to a user with minimal privileges. The Administration View provides access to other User XP features that allow Process and User management. (Various levels of access to User XP features can be given to or blocked from Users; the view below is the default version.)
4.1 Processes

With this control panel, you can:
- Manage Process life cycles
- Manage Steps in open Cases, consult Steps in archived Cases
- Define categories and use them to sort Cases

4.2 Organization

Define User names, roles, groups, and other User information.

4.3 Reporting

Consult and modify the Dashboard showing monitored activities. You can also download a .pdf version of a report.

4.4 User Labels

Define whether users can manually assign labels to their cases.

Part 5. Feedback, Questions, and More Information

If you explore a bit more in Bonita Open Solution, you will find many more functionalities not addressed in this QuickStart Guide. Follow the links below:

More Functionalities
For further explanation of the functionalities in Bonita Open Solution, see the Bonita Open Solution User and Reference Guide.

BonitaSoft Forum
We welcome your feedback on the BonitaSoft Forum. Ask your questions too. Use the BonitaSoft Forum to let us have it!
http://www.bonitasoft.org/forum/

BonitaSoft Community
Join the BonitaSoft Community and get our Newsletter, access detailed information, and more.
http://www.bonitasoft.org/register.php

Bug Tracker, Source Code
Check out our Bug Tracker, Source Code.
http://www.bonitasoft.org/index.php

More information
For more information, contact us at www.bonitasoft.com
http://www.bonitasoft.com/company/contact.php.

Have fun with Bonita!