Important Information

© Copyright Funambol, Inc. 2006. All rights reserved.

The information contained in this publication is subject to US and international copyright laws and treaties. Except as permitted by law, no part of this document may be reproduced or transmitted by any process or means without the prior written consent of Funambol, Inc.

Funambol, Inc. has taken care in preparation of this publication, but makes no expressed or implied warranty of any kind. Funambol, Inc. does not guarantee that any information contained herein is and will remain accurate or that use of the information will ensure correct and faultless operation of the relevant software, service or equipment.

Funambol, Inc., its agents and employees shall not be held liable for any loss or damage whatsoever resulting from reliance on the information contained herein.

Funambol and Sync4j are trademarks and registered trademarks of Funambol, Inc.

All other products mentioned herein may be trademarks of their respective companies.

Published by Funambol, Inc., 643 Bair Island Road, Suite 305, Redwood City, CA  94063
Contents

Introduction ................................................................. 1
Prerequisites ............................................................... 1

Installation ................................................................. 2
Obtaining the Software .................................................. 2
Installing the Software .................................................. 2
Accessing the Outlook Plug-in in Microsoft Outlook .......... 3
Configuring the Plug-in .................................................. 3
Uninstalling the Software ............................................... 3

Using the Funambol Outlook Plug-in ................................. 4
Home Screen ............................................................. 4
Main Menu Overview .................................................... 5
File Menu ................................................................. 6
Edit Menu ................................................................. 7
Help Menu ............................................................... 12

Resources ................................................................. 13
Related Documentation ................................................ 13
Other Resources ........................................................ 13
Introduction

The Funambol Outlook Plug-in provides synchronization functionality for Microsoft Outlook. After installing the software, you can synchronize data in Outlook with that stored in enterprise data sources, including email, PIM data, and files. This document described how to install, configure, and use the software.

Prerequisites

The system requirements for using the Funambol Outlook Plug-in are as follows:

- Microsoft Outlook 2000 or 2003.

For information on obtaining Microsoft Outlook, see “Other Resources” on page 13.
Installation

The section provides details for obtaining, installing and configuring the software.

Obtaining the Software

The Funambol Outlook Plug-in software is available as follows:

Download Site: www.funambol.com/opensource/downloads.html

File: funambol-outlook-plugin-3.0.x.exe

Size: 2.4 MB

The file contains the following:

- Funambol Outlook Plug-in version 3.0.x
- Outlook Redemption Library version 4.1. For details, see “Resources” on page 13.

Installing the Software

If a previous version of the plug-in is installed, you should uninstall that version before proceeding.

1. Run the executable installation file.

2. Review the license agreement. To accept the terms, select the checkbox and click Next.

3. Accept the suggested Destination Folder (i.e., the \Funambol\plug-ins\Funambol Outlook Plug-in directory) and click Next.

4. Accept the suggested Start Menu Folder (i.e., the \Funambol\Funambol Plug-ins\Outlook Plug-in) and click Install.

5. Review the Outlook Redemption license agreement. To accept the terms, select the “I agree” radio button and click Ok.

6. Click Finish to close the setup wizard.
Accessing the Outlook Plug-in in Microsoft Outlook

The installation process creates a ‘Funambol’ menu item on the Outlook main menu bar, with the following selections:

- **Funambol > Synchronize** – synchronize using the current settings.
- **Funambol > Configuration** – opens the plug-in as a separate application for configuration or other tasks.

The installation process also creates the Funambol icon (two circular arrows) on the Microsoft Outlook toolbar that performs the same action as the **Funambol > Synchronize** menu selection above.

**NOTE:** The plug-in can be started as a separate application via the Windows Start button.

Configuring the Plug-in

To configure the software, perform the following:

1. Start Microsoft Outlook and on the main menu bar select **Funambol > Configuration**. After the Outlook Plug-in standalone application opens, access the communication settings by selecting **Edit > Communication Settings**.  

   or

   Start the Funambol Outlook Plug-in standalone application in Windows by selecting **Start > All Programs > Funambol > Funambol Plug-Ins > Outlook Plug-in > Funambol Outlook Plug-in**. Access the communication settings by selecting **Edit > Communication Settings**.

2. Specify the following settings: SyncServer URL, Username, and Password and click **OK**. For details, see “Communication Settings” on page 7.

3. Choose the sources with which to synchronize, and set the appropriate parameters for each. For details, see “Synchronization Settings” on page 9. Note that default parameters are set on the Funambol server for synchronizing contacts and calendar.

Uninstalling the Software

To uninstall the software, perform the following: **Start > All Programs > Funambol > Funambol Plug-Ins > Outlook Plug-in > Uninstall.**
Using the Funambol Outlook Plug-in

This section introduces the features of the Funambol Outlook Plug-in.

Home Screen

When you start the Outlook Plug-in, the following screen appears:

This screen provides the following functionality:

- **Main menu** – access menus for synchronizing, specifying configuration settings, viewing a log file, and quitting the plug-in.
- **Synchronize button** – click to synchronize data using the current settings.
Main Menu Overview

The Funambol Outlook Plug-in main menu contains the following selections:

<table>
<thead>
<tr>
<th>Selection</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>File &gt; Synchronize</td>
<td>Synchronizes data using the current settings. This is the same as clicking the Synchronize button.</td>
</tr>
<tr>
<td>File &gt; Recover (slow-sync. . .)</td>
<td>Displays a window for choosing a source with which to perform a slow-synchronization.</td>
</tr>
<tr>
<td>File &gt; Exit</td>
<td>Exits the plug-in.</td>
</tr>
<tr>
<td>Edit &gt; Communication Settings</td>
<td>Displays a window for specifying communication settings.</td>
</tr>
<tr>
<td>Edit &gt; Synchronization Settings</td>
<td>Displays a window for specifying synchronization settings.</td>
</tr>
<tr>
<td>Edit &gt; Scheduler Settings</td>
<td>Displays a window for specifying scheduler settings.</td>
</tr>
<tr>
<td>Help &gt; View log</td>
<td>Displays the contents of the log file.</td>
</tr>
<tr>
<td>Help &gt; About</td>
<td>Displays the version number the plug-in.</td>
</tr>
</tbody>
</table>
File Menu

The File > Synchronize and File > Exit selections perform direct actions, i.e., synchronize using the current settings and quit the plug-in. The File > Recover (slow-sync)... selection displays the following window:

Choose the source with which to synchronize by checking the appropriate checkbox. Click Synchronize to start a slow-sync; click Cancel to close the window without synchronizing.
**Edit Menu**

You use the Edit menu to access the following settings:

- **Communication Settings** – the communication parameters between the Funambol Data Synchronization server and the plug-in.

- **Synchronization Settings** – the source to be synchronized, and preferences associated with synchronization with that source.

- **Scheduler Settings** – a time interval at which synchronization will automatically occur without user action.

**Communication Settings**

You access communication settings by selecting **Edit > Communication Settings**. The following window displays:

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>SyncServer URL</td>
<td>The URL of the synchronization server.</td>
</tr>
<tr>
<td>Username</td>
<td>The user ID used to access the database associated with the synchronization server.</td>
</tr>
<tr>
<td>Password</td>
<td>The password used to access the database associated with the synchronization server.</td>
</tr>
<tr>
<td>Proxy Settings</td>
<td>See “Proxy Settings” on page 8.</td>
</tr>
</tbody>
</table>

Click **OK** to save the settings; click **Cancel** to close the window without changes.
Proxy Settings

You access these settings by selecting Edit > Communication Settings and then clicking the Proxy Settings button, as shown below:

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Save Proxy Username / Password</td>
<td>Enables the proxy settings. If a proxy authorization is required and this checkbox is enabled, the plug-in will automatically connect through the proxy using the values specified for Username and Password. Otherwise, a window will display during synchronization process, prompting the user to specify the Username and Password. If no proxy connection is detected, these settings are ignored. If a proxy connection is detected but no authorization is required, these settings are ignored (the internet settings defined in the Windows control panel will be used).</td>
</tr>
<tr>
<td>Username</td>
<td>The username used to communicate through the proxy.</td>
</tr>
<tr>
<td>Password</td>
<td>The password used to communicate through the proxy.</td>
</tr>
</tbody>
</table>

If using a proxy that requires authentication, these settings are useful to avoid the repeated display of the proxy parameters window (for scheduled synchronizations). Click OK to save the settings, click Cancel to close the window without changes.
Synchronization Settings

You access synchronization settings by selecting Edit > Synchronization Settings. The following window displays:

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select the source with which to synchronize:</td>
<td>For the selected source, specify the type of synchronization. The valid selections are as follows:</td>
</tr>
<tr>
<td>• Contacts</td>
<td>• Normal – two-way fast synchronization.</td>
</tr>
<tr>
<td>• Calendar</td>
<td>• Replace Local Data – replaces the data on the client with the data from the server.</td>
</tr>
<tr>
<td>• Tasks</td>
<td>• Replace Remote Data – replaces the data on the server with the data on the client.</td>
</tr>
<tr>
<td>• Notes</td>
<td>• Update Local Data – updates the data on the client with the data from the server.</td>
</tr>
<tr>
<td>Encryption</td>
<td>• Update Remote Data – updates the data on the server with the data on the client.</td>
</tr>
<tr>
<td>Remote Settings</td>
<td>Enables content encryption using the 3DES algorithm (global parameter).</td>
</tr>
</tbody>
</table>
Click OK to save the settings; click Cancel to close the window without changes.

**Remote Settings**

You access these settings by selecting Edit > Synchronization Settings and then clicking the Remote Settings button, as shown below:

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Contact Name</td>
<td>String that represents the contacts synchronization source (i.e., the URI) on the server. The following strings are valid:</td>
</tr>
<tr>
<td></td>
<td>• <strong>scard</strong> – SIF</td>
</tr>
<tr>
<td></td>
<td>• <strong>card</strong> – v-Card (checkbox must be selected)</td>
</tr>
</tbody>
</table>
Click **OK** to save the settings, which are stored in the device registry and used in subsequent synchronizations. Click **Cancel** to close the window without changes.

### Scheduler Settings

You access scheduler settings by selecting **Edit > Scheduler Settings**. The following window displays:

![Scheduler Settings Window]

These settings specify a time interval at which synchronization will automatically occur without user action. To set a time interval, perform the following:

1. Select the **Activate** checkbox.
2. Specify the number of time units (i.e., number of minutes or number of hours).
3. Specify the time unit (i.e., minutes or hours).

Click **OK** to save the settings, **Cancel** to close the window without changes, or **View log** to view the log file.
Help Menu

You use the Help menu to access the following:

- **View log** – displays the log file.
- **About** – displays information about the software.

View log

You access the log file by selecting **Help > View log**, as shown below:

This selection opens the log file in Notepad.

About

You access information about the software by selecting **Help > About**, as shown below:
Resources

This section lists resources you may find useful.

Related Documentation

This section lists documentation resources you may find useful.

Funambol DS Server Documentation

The following documents form the Funambol DS Server documentation set:

- Funambol DS Server Architectural Overview: Read this document for an overview of the architecture.
- Funambol DS Server Administration Guide: Read this guide to gain an understanding of installation, configuration, and administration.
- Funambol DS Server Developer’s Guide: Read this guide to understand how to develop extensions to the server.
- Funambol DS Server SyncSource API: Read this reference guide for information on the SyncSource interface and related classes.
- Funambol DS Server Quick Start Guide: Read this guide to install and run a simple demonstration of synchronizing PIM data using the Funambol DS Server.
- Funambol DS Server Module Development Tutorial: Read this tutorial for instructions on packaging, installing and testing modules.

Other Resources

This section lists other resources you may find useful.

- For information on Microsoft Windows Outlook, visit http://www.microsoft.com/office/outlook/prodinfo/default.mspx.
- For information on Outlook Redemption, visit http://www.dimastr.com/redemption.