Funambol Windows Mobile Plug-in

User’s Guide

Version 3.0
September 2006
# Contents

**Introduction** ......................................................... 1

Prerequisites .......................................................... 1

**Installation** ............................................................ 2

Obtaining the Software .................................................. 2

Installing the Software ................................................... 3

Configuring the Plug-in ................................................. 4

Uninstalling the Software ............................................... 4

**Using the Funambol Windows Mobile Plug-in** ................. 5

Home Screen .............................................................. 5

Main Menu Overview .................................................... 6

File Menu ................................................................. 7

Edit Menu ................................................................. 8

Help Menu ............................................................... 18

**Resources** ............................................................ 19

Related Documentation ................................................ 19

Other Resources .......................................................... 19
Introduction

The Funambol Windows Mobile Plug-in provides synchronization functionality for mobile devices running on Microsoft Windows Mobile. After installing the software on your mobile device, you can synchronize the data on the device with that stored in enterprise data sources, including email, PIM data, and files. This document describes how to install, configure, and use the software.

Prerequisites

The system requirements for using the Funambol Windows Mobile Plug-in are as follows:

**Desktop or Portable Computer Used to Install the Plug-in on a Mobile Device**

- Microsoft Windows 2000 or XP.
- Microsoft ActiveSync 4.0 or 4.1.

**Mobile Device**

- Microsoft Windows Mobile 4.2.

For information on obtaining Microsoft Windows Mobile and Microsoft ActiveSync, see “Resources” on page 19.
Installation

The section provides details for obtaining, installing and configuring the software environment.

**Obtaining the Software**

The Funambol Windows Mobile Plug-in software is available as follows:

**Download Site:** [www.funambol.com/opensource/downloads.html](http://www.funambol.com/opensource/downloads.html)

**File:** funambol-windowsmobile-plugin-3.0.x.exe

**Size:** 2.5 MB

The file contains the following:

- Funambol Windows Mobile Plug-in version 3.0.x
- Funambol libraries for Windows Mobile
- Microsoft VB Runtime for Pocket PC
Installing the Software

Before proceeding, ensure that Microsoft ActiveSync is installed on your desktop/portable computer. If a previous version of the plug-in is installed on the mobile device, you will uninstall that version before installing the current version (as described below).

1. Connect your mobile device to the desktop/portable computer, e.g., via a USB cable.

2. On the desktop/portable computer, start Microsoft ActiveSync.

3. When ActiveSync recognizes device, the New Partnership windows displays. Select Guest partnership and click Next.

4. If a previous version of the plug-in is not installed on the device, skip to step 6. Otherwise, on the ActiveSync main menu bar, select Tools > Add/Remove Programs. The Add/Remove Programs windows displays.

5. In the list box, select the previous version of the plug-in and click Remove. A verification dialog box displays. Click OK.

6. Run the funambol-windowsmobile-plugin-3.0.x.exe file. A dialog box displays, asking permission to install the Funambol libraries in the default application installation directory on the device. Click Yes.

7. On the mobile device, verify that the Funambol libraries install without error. When complete, on the desktop/portable computer, click OK.

8. A dialog box displays, asking permission to install the Microsoft VB Runtime for Pocket PC in the default application installation directory on the device. Click Yes.

9. On the mobile device, verify that the VB Runtime installs without error. When complete, on the desktop/portable computer, click OK.

10. A dialog box displays, asking permission to install the Funambol Windows Mobile Plug-in in the default application installation directory on the device. Click Yes.

11. On the mobile device, verify that the plug-in installs without error. When complete, on the desktop/portable computer, click OK.

12. A dialog box displays, notifying you that the installation is complete. Click Done.
Configuring the Plug-in

To configure the software for your device, perform the following:

1. Start the Funambol Windows Mobile Plug-in.

2. Access the communication settings by selecting Edit > Communication Settings. Specify the following settings: Funambol Server URL, Username, and Password. For details, see “Communication Settings” on page 8.

3. Choose the sources with which to synchronize, and set the appropriate parameters for each. For details, see “Synchronization Settings” on page 9. Note that default parameters are set on the Funambol server for synchronizing contacts and calendar.

Uninstalling the Software

To uninstall the software, perform the following.

1. Uninstall the Funambol Windows Mobile Plug-in.

2. Uninstall the Funambol libraries for Windows Mobile.

3. Uninstall the Microsoft VB Runtime for Pocket PC.
Using the Funambol Windows Mobile Plug-in

This section introduces the features of the Funambol Windows Mobile Plug-in.

Home Screen

When you start the plug-in, the following screen appears:

In the diagram above, items A, B, C, D, F, and G are Windows Mobile features. The Funambol Windows Mobile Plug-in provides the following functionality:

- **Synchronize button (E)** – click to synchronize data using the current settings.
- **Funambol main menu (H)** – access menus for synchronizing, specifying configuration settings, viewing a log file, and quitting the plug-in.
Main Menu Overview

The Funambol main menu at the bottom of the screen contains the following selections:

<table>
<thead>
<tr>
<th>Selection</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>File &gt; Synchronize</td>
<td>Synchronizes data using the current settings. This is the same as clicking the Synchronize button.</td>
</tr>
<tr>
<td>File &gt; Recover (slow-sync...)</td>
<td>Displays a window for choosing a source with which to perform a slow-synchronization.</td>
</tr>
<tr>
<td>File &gt; Exit</td>
<td>Exits the plug-in.</td>
</tr>
<tr>
<td>Edit &gt; Communication Settings</td>
<td>Displays a window for specifying communication settings.</td>
</tr>
<tr>
<td>Edit &gt; Synchronization Settings</td>
<td>Displays a window for specifying synchronization settings.</td>
</tr>
<tr>
<td>Edit &gt; Log Settings</td>
<td>Displays a window for specifying log settings.</td>
</tr>
<tr>
<td>Help &gt; About</td>
<td>Displays the version number the plug-in.</td>
</tr>
<tr>
<td>Help &gt; View log</td>
<td>Displays the contents of the log file.</td>
</tr>
</tbody>
</table>
**File Menu**

You use the File menu to initiate a synchronization, or exit the plug-in (**File > Exit**).

**Synchronize**

Select **File > Synchronize** to start a synchronization using the current setting; the screen displays as follows:

![Synchronize Icon](image)

The Funambol icon (double arrows) appears in the title bar when the synchronization is in progress. You can stop the synchronization by clicking the this icon; this action displays a pop-up window that asks you to confirm that you want to stop the synchronization.

**Recover**

The **File > Recover (slow-sync)...** selection displays the following window:

![Recover Dialog](image)

Choose the source with which to synchronize by checking the appropriate checkbox. Click **Recover** to start a slow-sync; click **Cancel** to close the window without recovering.
**Edit Menu**

You use the Edit menu to access the following settings:

- **Communication Settings** – sets the communication parameters between the server and plug-in.
- **Synchronization Settings** – sets the source to be synchronized, and preferences associated with synchronization with that source.
- **Log Settings** – sets the log level.

**Communication Settings**

You access communication settings by selecting **Edit > Communication Settings**. You specify the settings on the window shown below:

The following communication settings are displayed:

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Funambol Server URL</td>
<td>The URL of the synchronization server.</td>
</tr>
<tr>
<td>Username</td>
<td>The user ID used to access the database associated with the synchronization server.</td>
</tr>
<tr>
<td>Password</td>
<td>The password used to access the database associated with the synchronization server.</td>
</tr>
<tr>
<td>Device Id</td>
<td>Read-only display of the device ID, which is sent to the server and used in user device mapping.</td>
</tr>
<tr>
<td>Current IP</td>
<td>Read-only display of the device’s current IP address.</td>
</tr>
</tbody>
</table>

Click the Windows **OK** button to save the settings; click **Cancel** to close the window without changes.
Synchronization Settings

You access synchronization settings by selecting **Edit > Synchronization Settings**. You specify the settings on the windows shown below:

![Initial Sync Settings Window](image1)

![More Mail Settings Window](image2)

The initial synchronization settings window displays the following settings:

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Select the source:</strong></td>
<td>Specifies the source with which to synchronize. For the selected source, you specify additional settings by clicking the “...” button, which displays the More &lt;source&gt; Settings window (e.g., More Mail Settings). These additional settings are described in subsequent sections.</td>
</tr>
<tr>
<td>• Contacts</td>
<td>To the right of each source, the current synchronization type is displayed; the possible types are as follows:</td>
</tr>
<tr>
<td>• Calendar</td>
<td>• <strong>None</strong> – no sync type defined (i.e., no sync with this source)</td>
</tr>
<tr>
<td>• Tasks</td>
<td>• <strong>Normal</strong> – normal type of synchronization</td>
</tr>
<tr>
<td>• Notes</td>
<td>• <strong>Replace local</strong> – replace data on the client with data from the server.</td>
</tr>
<tr>
<td>• Mail</td>
<td>• <strong>Replace remote</strong> – replace data on the server with data on the client.</td>
</tr>
<tr>
<td>• Files</td>
<td>• <strong>Update local</strong> – update data on the client with data from the server.</td>
</tr>
<tr>
<td>Encryption</td>
<td>• <strong>Update remote</strong> – update data on the server with data on the client.</td>
</tr>
<tr>
<td>Push Settings</td>
<td>To change the synchronization type of a source, access the More Settings window for the source.</td>
</tr>
</tbody>
</table>

| Encryption | Enables content encryption using the 3DES algorithm (global parameter). |
| Push Settings | Enable push synchronization and/or polling. For details, see “Push Settings” on page 16. |

Click the Windows **OK** button to save the settings; click **Cancel** to close the window without changes.
More Settings Window for Contacts, Calendar or Tasks

When you click the “…” button for a synchronization source, the More Settings window displays. If you select Contacts, Calendar, or Tasks as your synchronization source, the More Settings window displays the settings shown below:

![More Settings Window for Contacts, Calendar or Tasks](image)

The More Settings window for Contacts, Calendar and Tasks displays the following:

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
</table>
| **Synchronization Type** | Type of synchronization. The selections for all sources are as follows:  
  - **Normal** – two-way fast synchronization.  
  - **Replace Local Data** – replaces data on the client with data from the server. LOCAL DATA IS DELETED. When a synchronization is attempted, you receive an alert on the device asking you to confirm the deletion of local data. If you specify No, synchronization is not performed; if you do not respond to the alert within 10 seconds, it defaults to No.  
  - **Replace Remote Data** – replaces data on the server with data on the client.  
  - **Update Local Data** – updates data on the client with data from the server (no client modifications sent to server).  
  - **Update Remote Data** – updates data on the server with data on the client (no server modifications sent to client). |
| **Remote Name** | Name of the synchronization source (i.e., the URI) on the server. For Contacts, the following strings are provided:  
  - **scard** (SIF format)  
  - **card** (vCard format)  
  For Calendar, the following strings are valid:  
  - **scal** (SIF format)  
  - **cal** (iCalendar format)  
  For Tasks, this setting currently is not available. |
### Setting | Description
--- | ---
Synchronization Format | Data format of the synchronization. For Contacts, the selections are as follows:
- Use SIF Format
- Use vCard Format
For Calendar and Tasks, the selections are as follows:
- Use SIF Format
- Use iCalendar Format

Click the Windows **OK** button to save the settings, which are stored in the device registry and used in subsequent synchronizations. Click **Cancel** to close the window without changes.
More Settings Window for Notes or Files

If you select Notes or Files as your synchronization source, the More Settings window displays the settings shown below:

The More Settings window for Notes or Files displays the following:

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Synchronization Type</td>
<td>Type of synchronization. The selections for either source are as follows:</td>
</tr>
<tr>
<td></td>
<td>• <strong>Normal</strong> – two-way fast synchronization.</td>
</tr>
<tr>
<td></td>
<td>• <strong>Replace Local Data</strong> – replaces the data on the client with the data from the server. LOCAL DATA IS DELETED. When a synchronization is attempted, you receive an alert on the device asking you to confirm the deletion of local data. If you specify No, synchronization is not performed; if you do not respond to the alert within 10 seconds, it defaults to No.</td>
</tr>
<tr>
<td></td>
<td>• <strong>Replace Remote Data</strong> – replaces the data on the server with the data on the client.</td>
</tr>
<tr>
<td></td>
<td>• <strong>Update Local Data</strong> – updates data on the client with data from the server (no client modifications sent to server).</td>
</tr>
<tr>
<td></td>
<td>• <strong>Update Remote Data</strong> – updates data on the server with data on the client (no server modifications sent to client).</td>
</tr>
</tbody>
</table>
Click the Windows OK button to save the settings; click Cancel to close the window without changes.

**NOTE:**

The Funambol Windows Mobile Plug-in supports the synchronization of text notes only. While it is possible to save hand-written notes or drawings (as images) on a Pocket PC, these are not supported. When selecting a folder for notes synchronization using the “Choose directory” setting described above, you should ensure that folder only contains text notes. If you use graphic notes, save them in a folder other than that specified for the notes synchronization; otherwise, they could be lost during a synchronization.
More Settings Window for Mail

If you select Mail as your synchronization source, the More Settings window displays the settings shown below:

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Synchronization Type</td>
<td>Type of synchronization. The selections are as follows:</td>
</tr>
<tr>
<td></td>
<td>• Normal – two-way fast synchronization.</td>
</tr>
<tr>
<td></td>
<td>• Replace Local Data – replaces the data on the client with the data from</td>
</tr>
<tr>
<td></td>
<td>the server. LOCAL DATA IS DELETED. When a synchronization is attempted,</td>
</tr>
<tr>
<td></td>
<td>you receive an alert on the device asking you to confirm the deletion of</td>
</tr>
<tr>
<td></td>
<td>local data. If you specify No, synchronization is not performed; if you</td>
</tr>
<tr>
<td></td>
<td>do not respond to the alert within 10 seconds, it defaults to No.</td>
</tr>
<tr>
<td>Remote Name</td>
<td>Name of the synchronization source (i.e., the URI) on the server. The server</td>
</tr>
<tr>
<td>(text field in which the</td>
<td>is not configured with a default source. You need to create and configure</td>
</tr>
</tbody>
</table>
Click the Windows OK button to save the settings, or click Cancel to close the window without changes. You can specify additional settings by clicking the Folders, Filters, or Account buttons; see the descriptions for those settings on the next table.

When you click the Folders, Filters, or Account buttons, you can specify the following settings:

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Folders</td>
<td>Specify the folder(s) on the device to synchronize by selecting the desired checkbox. Files in the specified folder are synchronized; files in subdirectories of the folder are not synchronized.</td>
</tr>
</tbody>
</table>
| Filters  | The listboxes contain selections for specifying the parts of a message to download (i.e., header, body, attachments), and the total amount of data to download:  
- Get full messages – download body and attachments. When selected, you can specify the total amount of data to download in the listbox to the right.  
- Get header and body – download body only. When selected, you can specify the total amount of data to download in the listbox to the right.  
- Get header only – do not download message data. When selected, the listbox to the right is disabled.  
Download mail since – select this checkbox to specify filtering based on the age of the message on the device. |
| Account  | Display name – the name that is displayed for the account. Email address – the email address of the account. |

After specifying settings on these windows, click the Windows OK button to save the settings; click Cancel to close the window without changes. Either of these actions returns you to the More Mail Settings window.
Push Settings

You access push settings by selecting **Edit > Synchronization Settings > Push Settings**. You specify the settings on the window shown below:

The Push Settings window displays the following:

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
</table>
| Server push        | The device sends the IP address it is using to the server. If the server receives and can use the IP address for server-notified notifications, it sends a successful response, and the device starts listening for notifications. When new mail arrives for the user, the server sends notification, and the client starts a sync with the parameters set by the server.  
  • **Notification type** – SMS or TCP/IP  
  • **Port** – the port on which the device listens for notifications.  
  • **Ask Confirmation** – specifies whether to ask for confirmation before performing a synchronization. Yes = when a message is ready on the server, and the client is notified, the user receives an alert asking to confirm the synchronization. No = synchronization performed automatically. |
| Email polling      | Send an email synchronization request to the server at the specified interval. Used when a mobile operator does not give a public IP address. |

Click the Windows **OK** button to save the settings; click **Cancel** to close the window without changes.

**NOTE:** You can select both the **Server push** and **Email polling** settings. In this case, the latter will be used when the former is unavailable.
Log Settings

You access log settings by selecting Edit > Log Settings. You specify the settings on the window shown below:

The following log settings are displayed:

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>None</td>
<td>No data stored in the log file.</td>
</tr>
<tr>
<td>Info</td>
<td>Informational data stored in the log file.</td>
</tr>
<tr>
<td>Debug</td>
<td>Debug data stored in the log file.</td>
</tr>
</tbody>
</table>

When set to Info or Debug, the file contains the log only for the last synchronization. Click the Windows OK button to save the settings; click Cancel to close the window without changes.
Help Menu

You use the Help menu to access the following:

- **About** – displays information about the software.
- **View log** – displays the log file.

About

You access information about the software by selecting **Help > About**, as shown below:

View log

You access the log file by selecting **Help > View log**, as shown below:

This selection opens the log file in Pocket Word.
Resources

This section lists resources you may find useful.

Related Documentation

This section lists documentation resources you may find useful.

Funambol DS Server Documentation

The following documents form the Funambol DS Server documentation set:

- **Funambol DS Server Architectural Overview**: Read this document for an overview of the architecture.
- **Funambol DS Server Administration Guide**: Read this guide to gain an understanding of installation, configuration, and administration.
- **Funambol DS Server Developer’s Guide**: Read this guide to understand how to develop extensions to the server.
- **Funambol DS Server SyncSource API**: Read this reference guide for information on the SyncSource interface and related classes.
- **Funambol DS Server Quick Start Guide**: Read this guide to install and run a simple demonstration of synchronizing PIM data using the Funambol DS Server.
- **Funambol DS Server Module Development Tutorial**: Read this tutorial for instructions on packaging, installing and testing modules.

Other Resources

This section lists other resources you may find useful.